Требования

Мы создали мастер сервера, который проверит, совместим ли ваш сервер с ExpressionEngine. Для использования мастера:

Чтобы создать сайт на основе ExpressionEngine, вы должны иметь, по крайней мере, минимальный опыт работы с HTML и понимать, как создать веб сайт. Так же вы должны уметь загружать файлы на ваш сервер через FTP.

Для полного использования функциональных возможностей ExpressionEngine вы должны использовать браузер с включенным Javascript. Если Javascript отключен, то некоторые динамические функции в панели управления и других разделах сайта, возможно, не будут функционировать.

Требования к серверу

Дополнительные требования

Некоторые возможности ExpressionEngine не являются обязательными для использования. Однако чтобы их использовать, вам необходимо выполнить следующие требования.

Примечания

Сервер Apache

Если ваш хостинг использует веб сервер Apache, то он должен быть сконфигурирован с опцией AllowOverride=on для нормальной работы URL с настройками по умолчанию. Большинство серверов конфигурируется именно так, но если ваш нет, то существует три варианта:

  1. Вручную включить опцию, используя файл .htaccess.
  2. Связаться с вашим хостинг провайдером или администратором сервера, для того чтобы они включили эту опцию.
  3. Запустить ваш сайт, используя строки запроса. Смотрите "Строки запроса" в разделе концепция URL, для получения дополнительной информации.

Поддержка сегментов URL

Если в списке мастера сервера пункт URL Segment Support обозначен как Unsupported, то ваш сайт ExpressionEngine должен будет работать с использованием строк запроса. Раздел "Строки запроса" страницы концепция URL ExpressionEngine содержит необходимые подробности.

Наверх страницы